Autour de Laravel

Pb version php

Avatar de Valerie
Valerie

Bonjour, J'utilise le serveur Laragon Ma version php est la 7.2 Lorsque j'essaie d'installer laravelcollective ,j'obtiens une serie d'erreur comme celle ci mentionnant un pb de version php : "this package requires php ^7.2 -> your php version (5.6.40) does not satisfy that requirement" . J'ai bien configuré dans Menu -> PHP _> version 7.2. J'ai redémarré le serveur plusieurs fois, rien n'y fait . J'ai aussi essayé avec une autre version la 7.3, toujours le meme problème. J'ai vu sur le forum laragon.org le meme problème que le mien qui a été résolu par un redémarrage de laragon mais cela ne fonctionne pas pour moi. Auriez vous une idée ?

Posté il y a 9 mois
Avatar de bestmomo
bestmomo

Bonjour,

Essaie de réinstaller Laragon.

Posté il y a 9 mois
Avatar de bokino17
bokino17

Okk suis ce lien et tu ajoute

C:\laragon\bin\php\php7.3.7 

ou

C:\laragon\bin\php\php7.2
Posté il y a 9 mois
Avatar de Valerie
Valerie

Merci pour vos réponses. Malheureusement, cela ne fonctionne toujours pas. J'avais déjà réinstallé Laragon ainsi que la version light, redémarrer etc. J'ai essayé la solution de bokino17, mais sans succès, je vais continuer à chercher. Surtout n'hésitez pas si vous avez d'autres idées :) Toujours ceci après un php -v : PHP 5.6.40 (cli)

Posté il y a 9 mois
Avatar de MaitrePylos
MaitrePylos

Bonjour votre version n'est pas la 7.2 mais 5.6. Cela veut dire que vous avez un PHP 5.6 dans votre environement qui est configurer dans le path. Si vous voulez changer la version, soit vous reinstaller PHP, soit vous modifier votre Path, soit vous faites ceci dans votre projet

C:\laragon\bin\php\php7.2 composer require laravelcollective/html
Posté il y a 9 mois
Avatar de Valerie
Valerie

Bonjour MaitrePylos et merci pour la réponse j'avais bien la version 7.2 dans le path et j'avais aussi intallé la 7.3 pour test.

Je viens de tomber sur la solution https://stackoverflow.com/questions/39417152/how-to-upgrade-php-version-on-windows-10 qui était de réinstaller Composer qui pointait vers la version php 5.6 de mon serveur Wamp (J'utilisais wamp jusqu'à présent) . Je viens de réinstaller composer en pointant vers Laragon et la version php7.2 cela fonctionne.

Posté il y a 9 mois

Vous ne pouvez pas répondre à ce sujet.