Besoin d'aide ?

Comment utiliser Laravel avec un serveur web OVH ?

Avatar de Leamsi10
Leamsi10

Bonjour,

J'ai créé un site en local avec xampp et j'aimerais désormais le mettre en production. Pour cela, j'ai utilisé FileZila afin de transferer tous mes fichiers dans le dossier www du serveur. Ce que je me demande, c'est si c'était la bonne façon de faire... Est-ce que cela est ok ou bien dois-je créer un projet Laravel dans mon serveur et ensuite insérer mes fichiers aux bons endroits ?

Cordialement

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Bonjour,

Ca dépend de ce dont tu disposes sur le serveur. Si tu as un accès SSH tu peux utiliser un terminal pour faire des actions et ça facilite les choses. Tu te contentes d'envoyer en FTP les fichiers de ton application dans le dossier et ensuite tu utilises Composer pour charger le vendor, comme en local. Evidemment il faut adapter la configuration dans .env. Sans SSH c'est plus laborieux...

Posté il y a 1 mois
Avatar de Leamsi10
Leamsi10

Merci pour votre réponse. J'ai bien accès au ssh et le serveur est un serveur web pro . J'ai également adapté mon .env avec les données suivantes : DB_CONNECTION=mysql DB_HOST=nombdd.mysql.db DB_PORT=3306 //quel port mettre ? DB_DATABASE=Nom de la base DB_USERNAME=Nom d'utilisateur DB_PASSWORD=mdp

Quel port mettre pour DB_PORT ? Je laisse le 3306 ? Quelle est la commande pour charger vendor s'il vous plaît ?

Cordialement

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Sans renseignement supplémentaire il faut garder le port 3306.

Pour le vendor juste la commande d'installation classique avec l'option pour ne pas installer les packages de développement : composer install --no-dev

Posté il y a 1 mois
Avatar de Leamsi10
Leamsi10

Je viens d'effectuer la commande. Voici ce que cela m'a fait : https://imgur.com/a/v6uvv1U

J'ai toujours la page "site en construction" lorsque je veux aller sur mon site... Voici ce que j'ai dans www : https://imgur.com/a/twK1Nsm

Posté il y a 1 mois
Avatar de Leamsi10
Leamsi10

Bon, le site s'affiche correctement lorsque je fais cela : monsite.fr/public sauf que je ne veux pas de ce public dans l'url pour y accèder...

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Il faut faire pointer ton domaine sur le dossier public.

Posté il y a 1 mois

Vous ne pouvez pas répondre à ce sujet.