Besoin d'aide ?

commet resoudre ce prob..

Avatar de frantzynicolas
frantzynicolas

bonjour tout le monde je suis Frantzy Nicolas j'ai un problem avec LARAVEl 8, voici en gras le message dont j'ai quand je veux faire mon application merci de me donner un coup main. A noter qu eje travil avec ubuntu 21.04

**Your requirements could not be resolved to an installable set of packages.

Problem 1 - laravel/framework[v8.54.0, ..., 8.x-dev] require ext-mbstring * -> it is missing from your system. Install or enable PHP's mbstring extension. - Root composer.json requires laravel/framework ^8.54 -> satisfiable by laravel/framework[v8.54.0, ..., 8.x-dev].

To enable extensions, verify that they are enabled in your .ini files: - /etc/php/8.0/cli/php.ini - /etc/php/8.0/cli/conf.d/10-mysqlnd.ini - /etc/php/8.0/cli/conf.d/10-opcache.ini - /etc/php/8.0/cli/conf.d/10-pdo.ini - /etc/php/8.0/cli/conf.d/15-xml.ini - /etc/php/8.0/cli/conf.d/20-calendar.ini - /etc/php/8.0/cli/conf.d/20-ctype.ini - /etc/php/8.0/cli/conf.d/20-curl.ini - /etc/php/8.0/cli/conf.d/20-dom.ini - /etc/php/8.0/cli/conf.d/20-exif.ini - /etc/php/8.0/cli/conf.d/20-ffi.ini - /etc/php/8.0/cli/conf.d/20-fileinfo.ini - /etc/php/8.0/cli/conf.d/20-ftp.ini - /etc/php/8.0/cli/conf.d/20-gd.ini - /etc/php/8.0/cli/conf.d/20-gettext.ini - /etc/php/8.0/cli/conf.d/20-iconv.ini - /etc/php/8.0/cli/conf.d/20-intl.ini - /etc/php/8.0/cli/conf.d/20-mysqli.ini - /etc/php/8.0/cli/conf.d/20-pdo_firebird.ini - /etc/php/8.0/cli/conf.d/20-pdo_mysql.ini - /etc/php/8.0/cli/conf.d/20-phar.ini - /etc/php/8.0/cli/conf.d/20-posix.ini - /etc/php/8.0/cli/conf.d/20-readline.ini - /etc/php/8.0/cli/conf.d/20-shmop.ini - /etc/php/8.0/cli/conf.d/20-simplexml.ini - /etc/php/8.0/cli/conf.d/20-sockets.ini - /etc/php/8.0/cli/conf.d/20-sysvmsg.ini - /etc/php/8.0/cli/conf.d/20-sysvsem.ini - /etc/php/8.0/cli/conf.d/20-sysvshm.ini - /etc/php/8.0/cli/conf.d/20-tokenizer.ini - /etc/php/8.0/cli/conf.d/20-xmlreader.ini - /etc/php/8.0/cli/conf.d/20-xmlwriter.ini - /etc/php/8.0/cli/conf.d/20-xsl.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.**

Avatar de CinquièmeDimension
CinquièmeDimension

Salut,

C'est très simple: tu n'as pas l'extension PHP ext-mbstring. Installe-la et c'est bon !

==> https://qastack.fr/ubuntu/491629/how-to-install-php-mbstring-extension-in-ubuntu (l'exemple est en PHP7 et tu semble être en PHP8 mais je pense que tu vas arriver à adapter la commande)

Vérifie quand même que l'extension n'est pas juste désactivée dans ton php.ini

Vous ne pouvez pas répondre à ce sujet.