Besoin d'aide ?

installation d'un plugin qui échoue

  • Avatar de LienLien
    Membre depuis :
    23/12/2017
    Messages :
    14

    Bonjour,

    Je pense que j'aurai beaucoup de questions à vous poser, j'en ai une en ce qui concerne l'installation d'un plugin. Il s'agit de la laravel debugbar.

    Voici la page du plugin : https://github.com/barryvdh/laravel-debugbar

    J'essaie de l'installer mais j'obtiens cette erreur :

    c:\wamp64\www\blog>composer require barryvdh/laravel-debugbar --dev
    Using version ^3.2 for barryvdh/laravel-debugbar
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    - Conclusion: remove laravel/framework v6.9.0
    - Conclusion: don't install laravel/framework v6.9.0
    - way/generators 2.0 requires illuminate/support 4.1. -> satisfiable by illuminate/support[4.1.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
    - way/generators 2.1 requires illuminate/support 4.1.
    -> satisfiable by illuminate/support[4.1.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
    - way/generators 2.2 requires illuminate/support 4.1.* -> satisfiable by illuminate/support[4.1.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
    - way/generators 2.3 requires illuminate/support ~4.1 -> satisfiable by illuminate/support[4.1.x-dev, 4.2.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0-BETA1, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
    - way/generators 2.4 requires illuminate/support ~4.1 -> satisfiable by illuminate/support[4.1.x-dev, 4.2.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0-BETA1, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
    - way/generators 2.5 requires illuminate/support ~4.1 -> satisfiable by illuminate/support[4.1.x-dev, 4.2.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0-BETA1, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
    - way/generators 2.6 requires illuminate/support ~4.1 -> satisfiable by illuminate/support[4.1.x-dev, 4.2.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0-BETA1, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
    - way/generators 2.6.1 requires illuminate/support ~4.0 -> satisfiable by illuminate/support[4.0.x-dev, 4.1.x-dev, 4.2.x-dev, v4.0.0, v4.0.0-BETA2, v4.0.0-BETA3, v4.0.0-BETA4, v4.0.1, v4.0.10, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0-BETA1, v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9].
    - don't install illuminate/support 4.1.x-dev|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.0|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.1|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.10|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.11|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.12|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.13|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.14|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.15|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.16|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.17|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.18|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.19|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.2|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.20|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.21|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.22|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.23|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.24|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.25|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.26|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.27|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.28|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.29|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.3|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.30|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.4|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.5|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.6|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.7|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.8|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.1.9|don't install laravel/framework v6.9.0
    - don't install illuminate/support 4.2.x-dev|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.0-BETA1|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.1|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.12|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.16|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.17|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.2|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.3|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.4|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.5|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.6|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.7|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.8|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.2.9|don't install laravel/framework v6.9.0
    - don't install illuminate/support 4.0.x-dev|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.0|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.0-BETA2|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.0-BETA3|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.0-BETA4|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.1|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.10|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.2|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.3|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.4|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.5|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.6|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.7|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.8|don't install laravel/framework v6.9.0
    - don't install illuminate/support v4.0.9|don't install laravel/framework v6.9.0
    - Installation request for laravel/framework (locked at v6.9.0, required as ^6.2) -> satisfiable by laravel/framework[v6.9.0].
    - Installation request for way/generators ~2.0 -> satisfiable by way/generators[2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.6.1].

    Installation failed, reverting ./composer.json to its original content.

    Je ne comprends pas cette erreur et ça m'embête car 1) j'aimerais tester le plugin et 2) cette erreur va peut être se reproduire sur d'autres plugins

    Merci par avance pour votre aide

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    2632

    Salut,

    Je viens de tester la debugbar avec la dernière version de Laravel et ça fonctionne bien chez moi. Tu pars de quelle base ?

  • Avatar de LienLien
    Membre depuis :
    23/12/2017
    Messages :
    14

    Salut momo

    c:\wamp64\www\blog>php artisan --version
    Laravel Framework 6.9.0

    c:\wamp64\www\blog>
  • Avatar de LienLien
    Membre depuis :
    23/12/2017
    Messages :
    14

    Je mets à jour pour dire que j'ai trouvé.

    "require-dev": {
    .....
    "way/generators": "~2.0"", // <-- supprimer cette ligne
    }

    puis

    composer update

Vous ne pouvez pas répondre à ce sujet.