Besoin d'aide ?

Laravel 5.0.35

Avatar de momotoure
momotoure

Bonjour à tous, Merci à vous pour l'aide que vous nous fournissez et pour les efforts de reponses que aurez concernant ma préoccupation. En effet, je me suis lancé dans la programmation web, il ya peu. aussi je découvre réellement Laravel, avec tout son potentiel. je suis donc novice, pardonner moi d'avance. Mon souci est le suivant: j'ai réçu un projet conçut sous laravel 5.0.35 et fonctionnant dans l'environnement Linux (Ubuntu server). n'étant pas trop famillier avec linux, j'ai décidé de l'implémenter sous windows, et avec lecture de certains tutos, j''ai réussi à installer "composer" et les bibliothèques de laravel. Depuis cette migration de plateforme, mon projet ne marche plus. L'interpretation des erreurs m'ont orienté vers la mise à jour de mcrypt dans tous les dossiers PHP. Lorsque j'arrive à lancer le server malgré le manque de mcrypt j'ai ceci sur ma page : Warning: Use of undefined constant MCRYPT_RIJNDAEL_128 - assumed 'MCRYPT_RIJNDAEL_128' (this will throw an Error in a future version of PHP) in C:\Users\touma\Desktop\Files\aigf\config\app.php on line 83! . voilà un peu expliqué ma préoccupation. Merci pour vos réponses

Posté il y a 1 mois
Avatar de CinquièmeDimension
CinquièmeDimension

Salut,

Comment tu héberge ton site ? Un truc genre WAMP ou en ligne de commande ? Il serait intéressant de savoir ta version de PHP aussi... (Un php -v en console)

Sinon, si jamais tu as un repo git avec ton projet, on pourrait regarder le projet entier.

Posté il y a 1 mois
Avatar de momotoure
momotoure

ReSalut merci de me répondre, j'héberge mon site en local avec Wampserver 3.2 , la version du php utilisé par laravel est le 7.3 quand je tape la cmd php -v , honnêtement je pratique pas trop Git , je sais seulement que c'est un système qui sert à gerer les versions.

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Salut,

Si tu est avec Windows je te conseille d'utiliser Laragon.

Posté il y a 1 mois
Avatar de momotoure
momotoure

D'accord bestmomo, j'ai jamais utilisé, ce serait pour moi un challenge, jespere seulement que c'est pas trop compliqué. Merci bestmomo

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Laragon est certainement le système le plus simple pour utiliser Laravel. Le seul bémol c'est que pour la dernière version de Laravel, la 8, il faut PHP 7.3 et que par défaut Laragon installe la 7.2. Donc il faut après l'installation ajouter PHP 7.3 ou tant qu'à faire 7.4, ce qui n'est pas bien difficile. Il est aussi possible qu'il faille aussi actualiser Apache.

Posté il y a 1 mois

Vous ne pouvez pas répondre à ce sujet.