Laravel 5

Charger d'autres pages sur la page d'accueil

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    bonjour à tous, je suis entrain de travailler sur un projet de gestion d'école, j'ai créer une page d'accueil qui s'affiche après authentification , j'ai un sidebar sur lesquels j'ai créé des liens vers d'autres pages je veux les charger sur la page accueil , le problème est que je me retrouve déconnecté après les avoir chargé.

  • Avatar de CinquièmeDimension
    Membre depuis :
    18/04/2019
    Messages :
    37

    Salut,

    Comment as-tu géré les authentifications ?

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    j'ai fait une authentification qui me dirige vers la page d'accueil si c'est un succès

  • Avatar de devToure225
    Membre depuis :
    05/11/2018
    Messages :
    4

    comment tu gere tes templates /

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    j'ai intégré le template admin Lte à laravel, est celui que j'utilise.

  • Avatar de CinquièmeDimension
    Membre depuis :
    18/04/2019
    Messages :
    37

    J'ai mal posé ma question: comment as-tu géré l'autentification? Dans le sens, as-tu utilisé la ligne de commande php artisan make:auth qui te genere tout (migration, methodes, sessions, vues, etc.) ou tu as tout fait à la main ?

    Si tu n'as pas utilisé cette commande, il serait peut-être intéressant de refaire avec cette methode car elle est très complète et bien faite. Si tu l'as utilisée, tu as peut-être touché à la variable SESSION et supprimé ton token de connexion.

    Je parle ici de ton problème de déconnexion, pour l'affichage de plusieurs vues dans l'accueil, tu peux faire des includes. J'avais fait ça dans un projet à l'école pour afficher un chat via une requete AJAX qui appelais une vue de la conversation et la mettait dans un container de la vue du chat. C'est peut être une piste.

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    Pour l'authentification , je l'ai fait à la main,au niveau des incluses j'avais utilisé un @yield

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    je n'est pas utilisé les @includes

  • Avatar de F.M.
    Membre depuis :
    10/07/2017
    Messages :
    109

    Y'a des courageux sur ce forum, bravo à eux

  • Avatar de Philip
    Membre depuis :
    30/07/2019
    Messages :
    6

    bonjour à tous, pour régler le problème j'ai du recréé un nouveau projet , et ça marche maintenant. merci

Vous ne pouvez pas répondre à ce sujet.