Laravel 5

instalation de mix

  • Avatar de FelixTachi
    Membre depuis :
    27/09/2018
    Messages :
    10

    Bonjour cher tous!!
    je suis debutant dans laravel et j'utilise le tuto de ce lien https://laravel.sillo.org/laravel-5-7-par-la-pratique-installation-et-style/
    après plusieurs éssai je n'ai toujours pas webpack.mix.js
    stp aidez moi à corriger ce problème

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    2273

    Bonjour,

    webpack.mix.js est prévu de base dans l'installation de Laravel.

  • Avatar de FelixTachi
    Membre depuis :
    27/09/2018
    Messages :
    10

    j'ai essayé plusieurs fois l'execution de cette commande "composer create-project laravel/laravel albumplus --prefer-dist" mais il y a toujours pas ce fichier "webpack.mix.js" à la racine de mon dossier généré

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    2273

    Bizarre...

    Essaie de télécharger directement Laravel sur Github avec le bouton vert pour récupérer le ZIP. Tu décompresse dans ton dossier et tu lances composer install. Là au moins il y aura tout !

    Il faudra créer le fichier .env et générer un clé avec php artisan key:generate.

  • Avatar de FelixTachi
    Membre depuis :
    27/09/2018
    Messages :
    10

    bonjour bestmomo!! comment régler ce problme qui survient quant je tape composer install!
    $ composer install
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    • This package requires php ^7.1.3 but your PHP version (5.5.12) does not satisfy that requirement.
      Problem 2
    • laravel/framework v5.7.6 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.5 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.4 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.3 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.2 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.1 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework v5.7.0 requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • laravel/framework 5.7.x-dev requires php ^7.1.3 -> your PHP version (5.5.12) does not satisfy that requirement.
    • Installation request for laravel/framework 5.7.* -> satisfiable by laravel/framework[5.7.x-dev, v5.7.0, v5.7.1, v5.7.2, v5.7.3, v5.7.4, v5.7.5, v5.7.6].

    Afrikpay-admin@pc-PC MINGW64 /c/laragon/www/suiviPaiemtUds (slave)

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    2273

    Salut,

    Tu as la réponse dans l'erreur mentionnée, il faut PHP 7 et tu as la version 5.

    Tu utilises quoi comme serveur local ?

  • Avatar de FelixTachi
    Membre depuis :
    27/09/2018
    Messages :
    10

    laragon

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    2273

    Dans Laragon on peut facilement ajouter une version de PHP. Tu peux aussi réinstaller une verison de Laragon plus récente.

Vous ne pouvez pas répondre à ce sujet.