Laravel 5

Laravel avec Oracle

Avatar de KevinDoukpeni
KevinDoukpeni

Salut à tous J'aimerais utiliser une BD oracle avec mon projet Laravel Quelqu'un peut m'aider?

Posté il y a 2 mois
Avatar de bestmomo
bestmomo

Salut,

Il suffit d'installer ce package.

Posté il y a 2 mois
Avatar de KevinDoukpeni
KevinDoukpeni

Okay merci Je le fait et je te reviens

Posté il y a 2 mois
Avatar de KevinDoukpeni
KevinDoukpeni

./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - yajra/laravel-oci8 v6.0.4 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.3 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.2 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.1 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.0 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 6.0.x-dev requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - Installation request for yajra/laravel-oci8 ^6.0 -> satisfiable by yajra/laravel-oci8[6.0.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4].

To enable extensions, verify that they are enabled in your .ini files: - C:\PHP\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content.

Posté il y a 2 mois
Avatar de KevinDoukpeni
KevinDoukpeni

L'installation a échouée

Posté il y a 2 mois
Avatar de bestmomo
bestmomo

Salut,

Il faut ajouter l'extension indiquée oci8 à PHP.

Posté il y a 2 mois
Avatar de KevinDoukpeni
KevinDoukpeni

Rien n'a changé Toujours le même problème

Posté il y a 2 mois
Avatar de KevinDoukpeni
KevinDoukpeni

PHP Warning: PHP Startup: Unable to load dynamic library 'oci8_12c' (tried: C:\php\ext\oci8_12c (Le module spÚcifiÚ est introuvable.), C:\php\ext\php_oci8_12c.dll (%1 nÆest pas une application Win32 valide.)) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'oci8_12c' (tried: C:\php\ext\oci8_12c (Le module spÚcifiÚ est introuvable.), C:\php\ext\php_oci8_12c.dll (%1 nÆest pas une application Win32 valide.)) in Unknown on line 0 Using version ^6.0 for yajra/laravel-oci8 ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - yajra/laravel-oci8 v6.0.4 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.3 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.2 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.1 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 v6.0.0 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - yajra/laravel-oci8 6.0.x-dev requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system. - Installation request for yajra/laravel-oci8 ^6.0 -> satisfiable by yajra/laravel-oci8[6.0.x-dev, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4].

To enable extensions, verify that they are enabled in your .ini files: - C:\PHP\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Installation failed, reverting ./composer.json to its original content.

Posté il y a 2 mois
Avatar de bestmomo
bestmomo

J'ai trouvé cette discussion, peut-être une voie.

Posté il y a 2 mois

Vous ne pouvez pas répondre à ce sujet.