Laravel 5

Laravel install

  • Avatar de TavaresEvora
    Membre depuis :
    15/06/2016
    Messages :
    10

    Bonjour,
    J'ai un soucis lors de l'installation de laravel, lorsque je fait une install j'ai toujours la version '5.2. qui s'install et non la derniere 5.3. Je pense que le pb proviens de composer mais je ne trouve pas de solution.

    Merci

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1184

    Bonjour,

    Quelle commande tu utilises ?

  • Avatar de TavaresEvora
    Membre depuis :
    15/06/2016
    Messages :
    10

    composer create-project --prefer-dist laravel/laravel blog
    même en précisant la version 5.3 il ne se passe rien

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1184

    C'est bizarre, tu peux essayer une mise à jour de composer : composer self-update.

  • Avatar de TavaresEvora
    Membre depuis :
    15/06/2016
    Messages :
    10

    Déja essayé aussi, cache clear également. Peut être en réintallant composer

  • Avatar de Metrogeek
    Membre depuis :
    26/08/2016
    Messages :
    3

    Tente d'aller dans ~/.composer et de supprimer ton dossier cache, on ne sait jamais

  • Avatar de TavaresEvora
    Membre depuis :
    15/06/2016
    Messages :
    10

    Le probleme était du au faite que j'avais mal mis à jour ma version de php, du coup lors de l'install la derniere version compatible pour moi était la 5.2

    Merci

  • Avatar de FilipeSLB
    Membre depuis :
    02/01/2017
    Messages :
    7

    Bonjour,
    Je découvre et m'auto forme sur laravel et débutant que je suis je ne sais pas comment mettre à jour php.
    J'ai le même soucis lorsque j'installe laravel, j'ai à chaque fois la version 5.2 au lieu de la version 5.3.
    Est-ce que vous pouvez m'expliquer comment mettre à jour php svp.
    Merci d'avance,
    Filipe

  • Avatar de InformatiqueEurofrance
    Membre depuis :
    29/12/2016
    Messages :
    20

    La mise à jours de php dépends de ta platforme. Chez moi elle c'est fait quand j'ai migré d'ubuntu 14 à ubuntu 16.

  • Avatar de FilipeSLB
    Membre depuis :
    02/01/2017
    Messages :
    7

    Bonjour et merci.
    Je suis sur windows et je travaille pour le moment avec wampserver.
    Au pire je vais essayer de trouver sur le web.
    Merci.

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1184

    Salut,

    Sous Windows sans hésiter il vaut mieux utiliser Laragon.

  • Avatar de FilipeSLB
    Membre depuis :
    02/01/2017
    Messages :
    7

    Je viens d'installer Laragon et j'ai créé mon premier projet dessus, en version 5.3 enfin..!
    Génial, merci beaucoup car je ne connaissais pas!

    Si vous avez d'autres conseils ou astuces je suis preneur.

    Merci pour votre aide.

    Amicalement,
    Filipe.

  • Avatar de FilipeSLB
    Membre depuis :
    02/01/2017
    Messages :
    7

    Bonjour,
    Maintenant que j'utilise Laragon mon auto-formation se passe bien mais je viens de remarquer un problème au niveau de l'invité de commande qui ne fonctionne plus. J'utilisais l'invité de cmd de windows.
    Est-ce que c'est normal?
    Merci,
    Filipe

Vous ne pouvez pas répondre à ce sujet.