Laravel 5

Problem d'instalation de laravel

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    Salut, je suis un develloper en php et souhaite utiliser un fram work pour la premiere fois qui est laravel
    J'ais installer composer mais le probleme quand j'execute la commende d'installation qui est
    Via Composer Create-Project

    composer create-project --prefer-dist laravel/laravel blog "5.4.*"

    L'environnement de devellopement ce crée mais le dossier vendor n'aparait pas ce qui empeche le server de demarer

    Et quand jessaye de l'installer glabalement avec

    composer global require "laravel/installer"

    La commend repond: "laravel : commande introuvable"

    S'il vous plait veiller m'aider

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1526

    Salut,

    Pourquoi installer la version 5.4 ? La dernière version est la 5.5.

    Si le create-project ne passe pas tu peux télécharger le dossier sur github et installer avec composer install.

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    • The requested package laravel-master could not be found in any version, there may be a typo in the package name.

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

    Installation failed, reverting ./composer.json to its original content.

    Pouvez vous m'aporter une solution s'il vous plait ?

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    Could not find package laravel-master at any version for your minimum-stability (stable). Check the package spelling or your minimum-stabili
    ty

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1526

    Tu as entré quelle commande finalement ?

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    composer require laravel-master

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    Ensuit je tapez ceci: composer require "ivantree/yii2-vticker:*" pour la stabiliter mais sa marche pas encore

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1526

    Si tu es avec Windows je te conseille d'installer Laragon, ça va te simplifier la vie.

    Si tu es sous Linux alors installe Homestead.

  • Avatar de BlackSymbo
    Membre depuis :
    09/09/2017
    Messages :
    6

    Un grand merci pour votre aide

Vous ne pouvez pas répondre à ce sujet.