Laravel 5

Problème avec l'installation du driver YajraOci8

Avatar de Hugo
Hugo

Bonjour,

Je suis bloqué sur cette erreur depuis deja trop longtemps .... J'aimerai ajouter le rivers Yajra oci8 afin de communiquer avec une BDD oracle. Apres mon composer require : "composer require yajra/laravel-oci8" j'obtiens cette erreur :

Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is about to be released and the older 1.x releases will self-update directly to it once it is released. To avoid surprises update now to the latest 1.x version which will prompt you before self-updating to 2.x.
Using version ^8.0 for yajra/laravel-oci8
./composer.json has been updated
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is about to be released and the older 1.x releases will self-update directly to it once it is released. To avoid surprises update now to the latest 1.x version which will prompt you before self-updating to 2.x.
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework v5.8.38
    - Conclusion: don't install laravel/framework v5.8.38
    - yajra/laravel-oci8 8.x-dev requires illuminate/database ^8 -> satisfiable by illuminate/database[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.2.0, v8.3.0, v8.4.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - yajra/laravel-oci8 v8.0.0 requires illuminate/database ^8 -> satisfiable by illuminate/database[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.2.0, v8.3.0, v8.4.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - yajra/laravel-oci8 v8.0.1 requires illuminate/database ^8 -> satisfiable by illuminate/database[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.10.0, v8.11.0, v8.11.1, v8.11.2, v8.2.0, v8.3.0, v8.4.0, v8.5.0, v8.6.0, v8.7.0, v8.7.1, v8.8.0, v8.9.0].
    - don't install illuminate/database 8.x-dev|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.0.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.0.1|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.0.2|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.0.3|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.0.4|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.1.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.10.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.11.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.11.1|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.11.2|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.2.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.3.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.4.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.5.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.6.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.7.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.7.1|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.8.0|don't install laravel/framework v5.8.38
    - don't install illuminate/database v8.9.0|don't install laravel/framework v5.8.38
    - Installation request for laravel/framework (locked at v5.8.38, required as 5.8.*) -> satisfiable by laravel/framework[v5.8.38].
    - Installation request for yajra/laravel-oci8 ^8.0 -> satisfiable by yajra/laravel-oci8[8.x-dev, v8.0.0, v8.0.1].


Installation failed, reverting ./composer.json to its original content.

J'ai donc changé la version de laravel dans mon fichier "composer.json" mais toujours la même erreur ... (avec bien sur un composer update)

Merci de votre futur aide

Posté il y a 1 mois
Avatar de CinquièmeDimension
CinquièmeDimension

Salut,

Tu veux installer Laravel-OCI8 en version 8 soit la version compatible avec Laravel 8. Or, ta version de laravel est la 5.8... Il faudrait envisager d'installer un version invérieure ou d'urgrader Laravel (qui est beaucoup plus complèxe qu'un simple modif dans composer.json)

Un petit composer self-update aussi serait pas mal vu que tu semble avoir une version ancienne.

Posté il y a 1 mois
Avatar de Hugo
Hugo

Merci pour ta réponse,

Mon projet de base est en Laravel 5.7. Je vais donc le remettre comme il était. Si j'ai bien compris il faut que je spécifie ma version laravel sur ma commande composer ?

Posté il y a 1 mois
Avatar de DonDiegoAA
DonDiegoAA

Comme indiqué sur le github https://github.com/yajra/laravel-oci8, les versions de ce packages correspondent aux versions de Laravel, pratique, mais à noter que ce n'est pas toujours le cas pour tous les packages.

Tu dois donc en effet installer la version 5.7 du package:

composer require yajra/laravel-oci8:5.7.x

En regardant mieux ton message d'erreur, il semble que tu sois plutôt sur Laravel 5.8.38, donc ce serait

composer require yajra/laravel-oci8:5.8.x

D'autre part, tu dis avoir changé la version de Laravel dans ton composer, pour mettre la version 8 j'imagine. Mais attention, passer d'une version de Laravel à une autre n'est pas aussi simple que ça. Il faut suivre le guide d'upgrade que tu trouves sur Laravel.com.

Par exemple ici le guide pour passer de la 5.8 à la 6: https://laravel.com/docs/6.x/upgrade Ca prend du temps, et il faut souvent adapter certaines choses coté serveur, à commencer par la version de PHP.

La décision d'upgrader Laravel dans une version majeur n'est donc pas anodine, et pas toujours nécéssaire.

Posté il y a 1 mois
Avatar de Hugo
Hugo

Merci pour votre soutien, j'ai pu corriger mon problèmes avec vos réponses

Vous ne pouvez pas répondre à ce sujet.