Laravel 5

Problème avec l'installation du package image intervention

Avatar de lavarelkyi
lavarelkyi

Salut, Je cherche juste à installer un package du nom de: 'image intervention'. Mais j'obtient une erreure de la part de laravel

J'obtient ceci dans ma console lors de l'installation du package, ce qui fait que je ne peut installer ce package: '''

  • Root composer.json requires guzzlehttp/guzzle ^7.3, found guzzlehttp/guzzle[dev-master, 7.3.0, 7.4.x-dev (alias of dev-master)] but the package is fixed to 6.5.2 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
  • Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions. - Installation failed, reverting ./composer.json and ./composer.lock to their original content. '''

Merci de bien vouloir m'aider à resoudre ce problème

Posté il y a 2 mois
Avatar de CinquièmeDimension
CinquièmeDimension

Salut,

C'est plutôt clair. Intervention a besoin de guzzlehttp/guzzle ^7.3 mais ta version est fixeée à 6.5.2

Teste un composer update puis composer require intervention/image -W

Posté il y a 2 mois
Avatar de CinquièmeDimension
CinquièmeDimension

Salut,

C'est plutôt clair. Intervention a besoin de guzzlehttp/guzzle ^7.3 mais ta version est fixeée à 6.5.2

Teste un composer update puis composer require intervention/image -W

Posté il y a 2 mois

Vous ne pouvez pas répondre à ce sujet.