Laravel 5

Problemes pour debuter avec Laravel

  • Avatar de JeremieGodvaincAMETOKODO
    Membre depuis :
    29/11/2017
    Messages :
    3

    Bonjour tout le monde! J'essaie de débuter l'apprentissage de laravel et ca me met ca comme erreur:

    Warning: require(C:\wamp64\www\learning\public/../vendor/autoload.php): failed to open stream: No such file or directory in C:\wamp64\www\learning\public\index.php on line 24

    Comment régler ce problème?
    Merci d'avance!

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1673

    Bonjour,

    Comment tu as installé Laravel ?

  • Avatar de GoldoniFouotsa
    Membre depuis :
    29/11/2017
    Messages :
    1

    Salut,
    essayer =>composer install

  • Avatar de JeremieGodvaincAMETOKODO
    Membre depuis :
    29/11/2017
    Messages :
    3

    bestmomo il y a 32 minutes
    Bonjour,
    Comment tu as installé Laravel ?

    Premierement j'ai installé le setup de composer que j'ai telecharge sur le site getComposer.org
    J'ai ensuite executé cette commande:

    composer global require "laravel/installer"

    puis j'ai fait :

    laravel new nom_de_l'appli

  • Avatar de Farris27
    Membre depuis :
    31/10/2017
    Messages :
    10

    Salut,

    Essayez composer dump autoload-o :)

  • Avatar de JeremieGodvaincAMETOKODO
    Membre depuis :
    29/11/2017
    Messages :
    3

    Farris27 dans une heure
    Salut,

    Essayez composer dump autoload-o :)

    j'ai executé composer dump-autoload et ca me sort ca comme erreur:

    Generating optimized autoload files
    Class Illuminate\Foundation\ComposerScripts is not autoloadable, can not call post-autoload-dump script

    @php artisan package:discover

    Fatal error: Class 'Illuminate\Foundation\Application' not found in C:\wamp64\www\learning\bootstrap\app.php on line 14
    Script @php artisan package:discover handling the post-autoload-dump event returned with error code 255

    dois-je recommencer l'installation?

  • Avatar de bestmomo
    Membre depuis :
    07/04/2013
    Messages :
    1673

    Recommence tout avec l'installation classique :

    composer create-project --prefer-dist laravel/laravel nom_appli

    J'ai remarqué que laravel installer a parfois des bugs selon le systèmes et personnellement je ne m'en sers pas.

    Si tu es sous Windows je te conseille Laragon plutôt que wamp. Il est fait pour Laravel et tellement plus convivial !

Vous ne pouvez pas répondre à ce sujet.