Laravel 6

Problème d'affichage d'image dans Voyager

Avatar de mr_debutant
mr_debutant

Bonjour à tous,

J'ai un petit problème d'affichage de mes images dans mon panel d'administration, quand il n'y en a qu'une l'image en question s'affiche mais quand il y en plusieurs y en a aucune qui s'affiche. Ces images sont des images de produits qui sont enregistrées après avoir effectuer une commande. Lorsque je regarde dans ma table en base de données, mes images sont bien enregistrées mais impossible de les afficher dans voyager. De plus, dans mon bread l'input type de la colonne dans laquelle sont censé s'afficher les produits est Image.

Voici le bout de code qui permet d'enregistrement des élèments constituants la colonne dont les images :

        $products = [];
        $images = "";
        $references = "";
        $i = 1;
             
        foreach (Cart::content() as $product) {
            $products['product_' . $i][] = $product->model->title_generale;
            $products['product_' . $i][] = $product->model->reference;
            $products['product_' . $i][] = $product->qty;
            $images .= $product->model->image_generale . " "; 
            $references .= $product->model->reference . "|"; 
            $i++;
        }
        
        $order->products = serialize($products);
        $order->image_products = $images; 
        $order->reference = $references;
        $order->user_id = Auth()->user()->id;
        $order->adresse = Auth()->user()->nom_livraison . ' ' . Auth()->user()->prenom_livraison . "\n" . Auth()->user()->numero . ' ' . Auth()->user()->type_de_la_voie . ' ' . Auth()->user()->nom_de_la_voie
        . "\n" . Auth()->user()->code_postale . ' ' . Auth()->user()->ville . "\n" . Auth()->user()->region ; 
        $order->save();

Si quelqu'un pourrait m'aider, ça serait vraiment cool ^^

Merci d'avance ^^

Vous ne pouvez pas répondre à ce sujet.