Laravel France

Ignition Laravel ne s'installe pas

Avatar de HugesStorm
HugesStorm

Bonjour à tous,

Je lance en ligne de commande DOS : composer require facade/ignition J'ai:

Using version ^2.0 for facade/ignition ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Conclusion: don't install facade/ignition 2.0.7 - Conclusion: don't install facade/ignition 2.0.6 - Conclusion: don't install facade/ignition 2.0.5 - Conclusion: don't install facade/ignition 2.0.4 - Conclusion: don't install facade/ignition 2.0.2 - Conclusion: don't install facade/ignition 2.0.1 - Conclusion: don't install facade/ignition 2.0.0 - Conclusion: remove laravel/framework v6.18.24 - Installation request for facade/ignition ^2.0 -> satisfiable by facade/ignition[2.0.0, 2.0.1, 2.0.2, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.x-dev]. - Conclusion: don't install laravel/framework v6.18.24 - facade/ignition 2.x-dev requires illuminate/support ^7.0|^8.0 -> satisfiable by illuminate/support[7.x-dev, 8.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0, v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2]. - don't install illuminate/support 7.x-dev|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.3|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.4|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.5|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.6|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.7|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.0.8|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.1.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.1.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.1.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.1.3|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.10.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.10.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.10.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.10.3|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.11.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.12.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.13.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.14.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.14.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.15.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.16.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.16.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.17.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.17.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.17.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.18.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.19.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.2.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.2.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.2.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.3.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.4.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.5.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.5.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.5.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.6.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.6.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.6.2|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.7.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.7.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.8.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.8.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.9.0|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.9.1|don't install laravel/framework v6.18.24 - don't install illuminate/support v7.9.2|don't install laravel/framework v6.18.24 - don't install illuminate/support 8.x-dev|don't install laravel/framework v6.18.24 - Installation request for laravel/framework (locked at v6.18.24, required as ^6.2) -> satisfiable by laravel/framework[v6.18.24].

Installation failed, reverting ./composer.json to its original content.

J'ai regardé dans le fichier composer.lock et j'ai "name": "laravel/framework", "version": "v6.18.24",

Pouquoi ça ne fonctionne pas. Je stagne depuis + de 2h dessus. J'ai regardé ce lien, sans succès : https://laracasts.com/discuss/channels/general-discussion/how-to-install-ignition Svp, besoin de vos compétences en info. Merci.

Posté il y a 1 mois
Avatar de bestmomo
bestmomo

Salut,

D'après le texte de l'erreur la version 2 de Ignition demande la version 7 de Laravel. Sans doute pour la version 6 il doit falloir aller chercher une version antérieure d'Ignition.

Avatar de HugesStorm
HugesStorm

bestmomo, merci. J4ai installé la version 6. Faut résinstaller la version 7 ...Merci d'avoir répondu. Très ympa ce que vous faites.

Vous ne pouvez pas répondre à ce sujet.